Fully featured low overhead profiler for Java EE and Java SE platforms.
Performance monitoring and profiling of Jenkins, TeamCity, Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

alpine 3.9

Moderators: Vladimir Kondratyev, Anton Katilin

alpine 3.9

Postby simao » Thu Apr 04, 2019 12:32 pm

I am trying to use yourkit following the instruction at https://www.yourkit.com/docs/java/help/docker.jsp

I am still getting the following error:

Code: Select all
Could not find agent library /usr/local/YourKit-JavaProfiler-2019.1/bin/linux-x86-64/libyjpagent.so in absolute path, with error: Error loading shared library ld-linux-x86-64.so.2: No such file or directory (needed by /usr/local/YourKit-JavaProfiler-2019.1/bin/linux-x86-64/libyjpagent.so)


libc6-compat is installed. The output of ldd:

Code: Select all
/usr/local/YourKit-JavaProfiler-2019.1/bin/linux-x86-64 # ldd libyjpagent.so
   ldd (0x7fb68c800000)
   librt.so.1 => ldd (0x7fb68c800000)
   libdl.so.2 => ldd (0x7fb68c800000)
   libm.so.6 => ldd (0x7fb68c800000)
   libc.so.6 => ldd (0x7fb68c800000)
Error loading shared library ld-linux-x86-64.so.2: No such file or directory (needed by libyjpagent.so)


Any ideas?
simao
 
Posts: 1
Joined: Thu Apr 04, 2019 12:26 pm

Re: alpine 3.9

Postby Anton Katilin » Thu Apr 04, 2019 6:34 pm

libc6-compat is installed.

Do you have the following command in the Dockerfile?
Code: Select all
RUN apk add --no-cache libc6-compat
Anton Katilin
 
Posts: 5825
Joined: Wed Aug 11, 2004 8:37 am


Return to Java Profiler

Who is online

Users browsing this forum: No registered users and 14 guests

cron

YourKit uses cookies and other tracking technologies to improve your browsing experience on our website, to show you personalized content and targeted ads, to analyze our website traffic, and to understand where our visitors are coming from.

By browsing our website, you consent to our use of cookies and other tracking technologies in accordance with the Privacy Policy.