Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

.net 4.6 issues?

Moderators: Vladimir Kondratyev, Anton Katilin

.net 4.6 issues?

Postby korre » Tue Jun 16, 2015 2:38 pm

Hi!
I have not been using Yourkit (2014) for a long time. Recently when I started it to profile an w3wp it did not work. Yourkit restarted IIS successfully and showed the green light. I could click on the process and it was showing correctly. *But* when I clicked to profile cpu it hung the w3wp process. That is it became totally unresponsive. I tested also by just attaching to a non profiled w3wp process and that worked perfectly, so attach mode worked. So my longwinded ranting ends with the only thing I know that I have changed recently, my installation of Visual Studio 2015 and hence .net 4.6. Any known issues? (i also tested Yourkit 2015 but it beahved exactly the same)

Konstantin
korre
 
Posts: 2
Joined: Fri May 04, 2007 8:35 am

Re: .net 4.6 issues?

Postby Anton Katilin » Wed Jun 17, 2015 10:26 am

Hello Konstantin

It's a new issue. We're investigating.

It would be great if you could provide the profiler agent log file for the problematic w3wp session. It is located in <process user's home directory>\.ynp\log
If you can't share the log file content in the forum could you please send it to support@yourkit.com

Best regards,
Anton
Anton Katilin
 
Posts: 5568
Joined: Wed Aug 11, 2004 8:37 am

Re: .net 4.6 issues?

Postby Anton Katilin » Wed Jun 17, 2015 12:11 pm

An update: we didn't manage to reproduce the problem with .net 4.6.
Anton Katilin
 
Posts: 5568
Joined: Wed Aug 11, 2004 8:37 am


Return to .NET Profiler

Who is online

Users browsing this forum: No registered users and 1 guest