Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

Profiling devenv.exe with 4.5.0

Moderators: Vladimir Kondratyev, Anton Katilin

Profiling devenv.exe with 4.5.0

Postby dmatveev » Tue Sep 08, 2009 11:27 am

Hello!
I've tried to use new version (4.5.0) of YourKit .NET profiler and it seems to have some problems with profiling Visual Studio 2005 instances (process name: devenv.exe). After Visual Studio is started there are few seconds then devenv.exe process is visible in "Monitor Local Applications" frame and it's possible to connect to this process, but then devenv.exe process is removed from process list and in connection window there is a message saying: "Local application "devenv.exe" at port N has terminated or connection is lost". The VS process isn't terminated at this point. Version 4.0.8 isn't suffering from that issue.

The profiling is enabled for all applications (all predefined exceptions are removed) and other applications are successfully can be profiled.
dmatveev
 
Posts: 4
Joined: Tue Sep 08, 2009 11:15 am

Re: Profiling devenv.exe with 4.5.0

Postby Anton Katilin » Tue Sep 08, 2009 12:04 pm

Hello,

Thank you for the report.

This behavior is cased by a Visual Studio profiler plugin which leads to incorrect detection of devenv.exe by the profiler. We'll fix this problem in 4.5.1.

This problem only affects devenv.exe which cannot be profiled itself, which should not be a problem unless you develop VS or its plugins. Other applications are not affected.

Best regards,
Anton
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am

Re: Profiling devenv.exe with 4.5.0

Postby dmatveev » Tue Sep 08, 2009 12:10 pm

The project I want to profile is VS plugin. Can I workaround this somehow? Can I disable VS extension and is there any chances that this will help me?
dmatveev
 
Posts: 4
Joined: Tue Sep 08, 2009 11:15 am

Re: Profiling devenv.exe with 4.5.0

Postby dmatveev » Tue Sep 08, 2009 12:22 pm

I've disabled profiler add-in and now everything is working fine. Thank you.
dmatveev
 
Posts: 4
Joined: Tue Sep 08, 2009 11:15 am

Re: Profiling devenv.exe with 4.5.0

Postby Anton Katilin » Tue Sep 08, 2009 12:50 pm

Please try 4.5.1:
http://www.yourkit.com/dotnet/download/ ... r-.NET.exe

Could you please confirm that it solves the problem.

(Please do not forget to uninstall 4.5.0 before installing 4.5.1)
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am

Re: Profiling devenv.exe with 4.5.0

Postby dmatveev » Wed Sep 09, 2009 2:28 am

Yes, it solves the problem. Thank you.
dmatveev
 
Posts: 4
Joined: Tue Sep 08, 2009 11:15 am

Re: Profiling devenv.exe with 4.5.0

Postby Anton Katilin » Wed Sep 09, 2009 10:47 am

Thank you for the notification.
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am


Return to .NET Profiler

Who is online

Users browsing this forum: No registered users and 1 guest