Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

No applications show up to monitor

Moderators: Vladimir Kondratyev, Anton Katilin

No applications show up to monitor

Postby pcleary@intralinks.com » Wed Jul 23, 2008 3:24 pm

After starting any .net application the application reference never shows up in the "Monitor Applications" section. The Example application does not show up either after starting.
pcleary@intralinks.com
 
Posts: 3
Joined: Wed Jul 23, 2008 3:18 pm

Postby Anton Katilin » Wed Jul 23, 2008 4:04 pm

What is the version of Windows?
Anton Katilin
 
Posts: 5575
Joined: Wed Aug 11, 2004 8:37 am

Postby pcleary@intralinks.com » Wed Jul 23, 2008 4:06 pm

Microsoft Windows XP [Version 5.1.2600]
pcleary@intralinks.com
 
Posts: 3
Joined: Wed Jul 23, 2008 3:18 pm

Postby Anton Katilin » Wed Jul 23, 2008 4:12 pm

Do you have antivirus/firewall software installed? Communication with profiled application is performed via socket on local port. Possibly, it has been blocked by such software.
Anton Katilin
 
Posts: 5575
Joined: Wed Aug 11, 2004 8:37 am

Postby pcleary@intralinks.com » Wed Jul 23, 2008 5:25 pm

I am not running any local firewall.

When running the sample application the message is :

"There's no application running at localhost with profiler agent configured to listen on port 1225"

This is while the test application is clearly running.[/img]
pcleary@intralinks.com
 
Posts: 3
Joined: Wed Jul 23, 2008 3:18 pm

Postby Anton Katilin » Thu Jul 24, 2008 1:21 pm

Can you connect via "File | Connect to Remote Application...", entering "localhost:1225"? For the demo application the port is chosen automatically, so please change "1225" to the value shown in the message ""There's no application running at localhost..."
Anton Katilin
 
Posts: 5575
Joined: Wed Aug 11, 2004 8:37 am

Postby Anton Katilin » Thu Jul 24, 2008 2:18 pm

Also, could you please send logs from <user home>/.ynp/log to support@yourkit.com
Anton Katilin
 
Posts: 5575
Joined: Wed Aug 11, 2004 8:37 am

Re: No applications show up to monitor

Postby johncdoherty » Thu Sep 18, 2008 6:33 pm

Is there a solution for this yet. I am having the same problem. Is there a way to change which port the app uses?
Thanks
johncdoherty
 
Posts: 1
Joined: Thu Sep 18, 2008 5:38 pm

Re: No applications show up to monitor

Postby Vladimir Kondratyev » Wed Sep 24, 2008 10:42 am

johncdoherty , what is the exact version of your operating system? What is the output of "ver" command?
Vladimir Kondratyev
 
Posts: 1444
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany

Re: No applications show up to monitor

Postby Tobbe » Fri Oct 03, 2008 1:43 pm

Hi

I'am also have this problem. Trying yourkit in VirtualBox environment with Microsoft Windows XP [Version 5.1.2600] OS.
Tobbe
 
Posts: 72
Joined: Thu Feb 21, 2008 11:08 am

Re: No applications show up to monitor

Postby Vladimir Kondratyev » Fri Oct 03, 2008 2:09 pm

Tobbe, please provide more information about your VirtualBox environment.

What is host OS (full version)? The guest is Microsoft Windows XP [Version 5.1.2600], right?
Vladimir Kondratyev
 
Posts: 1444
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany

Re: No applications show up to monitor

Postby Tobbe » Fri Oct 03, 2008 6:11 pm

Code: Select all
00:00:00.395 VirtualBox 2.0.2 r36488 win.x86
00:00:00.395 OS Product: Windows XP Professional
00:00:00.395 OS Release: 5.1.2600
00:00:00.395 OS Service Pack: 3


Host and guest run the same version of windows.
Tobbe
 
Posts: 72
Joined: Thu Feb 21, 2008 11:08 am

Re: No applications show up to monitor

Postby Vladimir Kondratyev » Tue Oct 07, 2008 2:27 pm

Tobbe, I've managed to reproduce this problem in similar VirtualBox environment only in case when .NET framework was not installed when you install profiler.

Do you have .NET framework (at least 1.1) installed? If .NET framework is installed, please try to reinstall profiler.
Vladimir Kondratyev
 
Posts: 1444
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany

Re: No applications show up to monitor

Postby Tobbe » Wed Oct 08, 2008 5:53 am

Vladimir Kondratyev wrote:Tobbe, I've managed to reproduce this problem in similar VirtualBox environment only in case when .NET framework was not installed when you install profiler.


Your absolutly right, I installed the profiler first, then the framework!

Will try your solution later and report back.
Tobbe
 
Posts: 72
Joined: Thu Feb 21, 2008 11:08 am

Re: No applications show up to monitor

Postby Tobbe » Wed Oct 08, 2008 6:56 pm

Thanks Vladimir

Reinstalled yourkit, now working.
Tobbe
 
Posts: 72
Joined: Thu Feb 21, 2008 11:08 am

Next

Return to .NET Profiler

Who is online

Users browsing this forum: No registered users and 1 guest