Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

Windows Server 2003 R2 X64 supported?

Moderators: Vladimir Kondratyev, Anton Katilin

Windows Server 2003 R2 X64 supported?

Postby RolandSchneider » Tue Jun 10, 2008 1:23 pm

I'm unable to profile any application on our 64 bit machine:
- Windows Server 2003 R2 Standard X64
- YourKit 3.0.5 for .NET
- .NET Framework 3.5
- Firewall turned off.

When trying to profile the demo application I get the following message box:
There's no application running at localhost with profiler agent configured to listen on port 1442.

I cannot find anything in the YourKit .NET help about how to configure the "profiler agent" for an application.
RolandSchneider
 
Posts: 4
Joined: Tue Jun 10, 2008 1:05 pm

Postby Anton Katilin » Tue Jun 10, 2008 2:56 pm

Hello,

Could you please try the following:

1. Make sure profiling is enabled on the Welcome screen
2. Manually start the demo executable <profiler installation directory>\samples\demo\Demo.exe

Does the demo start?

Is it detected and shown on the Welcome screen?

Best regards,
Anton
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am

Postby RolandSchneider » Tue Jun 10, 2008 3:41 pm

Hello Anton,

thanks for Your immediate response.

YourKit demo was installed in C:\Program Files (x86)\YourKit Profiler 3.0.5 for .NET\samples\demo

I manually started demo.exe from that location while YourKit was running with "Profiling enabled" light bulb on. demo.exe started properly (as a 64bit process) but was not listed in the "Monitor Applications" list.

I copied the demo project and recompiled it (using VS2008) as a 32bit process. demo.exe was shown as a 32bit process in Task Manager, but result is the same as before: Nothing displayed in "Monitor Applications" list.

Any further ideas?

Roland.
RolandSchneider
 
Posts: 4
Joined: Tue Jun 10, 2008 1:05 pm

Postby Anton Katilin » Tue Jun 10, 2008 4:14 pm

We're trying to reproduce the problem.

There can be 2 reasons why the application does not show up.

1. It starts with the profiler agent but cannot be automatically detected by the profiler client.

When demo.exe is running (either 32 or 64-bit version), does "File | Connect to Remote Application..." find it (please use localhost as host name)?

2. It starts without the profiler agent.

When an application starts with the profiler, in <user home>\.ynp\log a file named <pid>.log is created. Could you please check if the file is created in your case with the pid as shown in the task manager?
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am

Postby RolandSchneider » Tue Jun 10, 2008 5:00 pm

1. It starts with the profiler agent but cannot be automatically detected by the profiler client.

When demo.exe is running (either 32 or 64-bit version), does "File | Connect to Remote Application..." find it (please use localhost as host name)?


A message box is shown: "No application being profiled can be automatically detected on host localhost".

2. It starts without the profiler agent.

When an application starts with the profiler, in <user home>\.ynp\log a file named <pid>.log is created. Could you please check if the file is created in your case with the pid as shown in the task manager?


For the profiled application (demo.exe) there is no <pid>.log file.

For the YourKit GUI (javaw.exe) there is 8648.log with the following contents:
[ 0.836] winver=5002

Besides there is 0.log with the following content:
2008-06-10 18:03:41.859 INFO com.yourkit.Main0 : ---------------------------------------------------------------------
2008-06-10 18:03:41.859 INFO com.yourkit.Main0 : Starting YourKit Profiler 3.0.5 for .NET build #362; built on Tue Mar 04 19:14:00 CET 2008
2008-06-10 18:03:41.859 INFO com.yourkit.Main0 : number of args: 0

So obviously the profiler agent doesn't attach to the profiled applications. Is there a possibility to manually configure the profiler agent for (specific) processes?
RolandSchneider
 
Posts: 4
Joined: Tue Jun 10, 2008 1:05 pm

Postby Anton Katilin » Wed Jun 11, 2008 10:57 am

To enable profiling, the following registry keys are set:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\COR_ENABLE_PROFILING =1

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\COR_PROFILER ={3F0A62D8-48B8-412F-BC78-2FE01E5C4B9A}

(GUID {3F0A62D8-48B8-412F-BC78-2FE01E5C4B9A} is for version 3.0.5 of the profiler)

When the profiling is enabled from the Welcome screen, these keys should be automatically set.
Could you please check if they are set on your machine.
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am

Postby RolandSchneider » Wed Jun 11, 2008 1:14 pm

The settings in the registry key while YourKit is running and profiling is enabled are:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework]
"Enable64Bit"=dword:00000001
"DbgManagedDebugger"="\"C:\\WINNT\\system32\\VSJitDebugger.exe\" PID %d APPDOM %d EXTEXT \"%s\" EVTHDL %d"
"DbgJITDebugLaunchSetting"=dword:00000010
"sdkInstallRootv2.0"="C:\\Program Files\\Microsoft.NET\\SDK\\v2.0 64bit\\"
"InstallRoot"="C:\\WINNT\\Microsoft.NET\\Framework64\\"
"COR_ENABLE_PROFILING"=dword:00000001
"COR_PROFILER"="{3F0A62D8-48B8-412F-BC78-2FE01E5C4B9A}"
"YNP_TRACING_DISABLED"=dword:00000000

I had to switch to a slightly different machine today, but it shows the same problem.
RolandSchneider
 
Posts: 4
Joined: Tue Jun 10, 2008 1:05 pm

Postby c.h. » Sat Jul 12, 2008 8:16 am

i have the same problem on same configuration.

if i can run yourkit on windows server 2003, we want to use this tool.
c.h.
 
Posts: 1
Joined: Sat Jul 12, 2008 8:14 am


Return to .NET Profiler

Who is online

Users browsing this forum: No registered users and 1 guest