Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

Open declaration in Visual Studio not working

Moderators: Vladimir Kondratyev, Anton Katilin

Open declaration in Visual Studio not working

Postby arylwen » Wed Feb 06, 2008 7:56 pm

We are evaluating Yourkit and we have it installed on the D drive of a 2003 VMWare virtual machine. Visual Studio is installed in E with the core on the C drive.

Here is the stack trace when yourkit tries to invoke visual studio. Please advise.

2008-02-06 13:14:57.687 INFO com.yourkit.b.d :
java.lang.Exception
at com.yourkit.b.d.if(a:231)
at com.yourkit.b.d.a(a:189)
at com.yourkit.b.a.if(a:33)
at com.yourkit.ui.g.a.actionPerformed(a:20)
at com.yourkit.ui.ax.a(a:21)
at com.yourkit.ui.ax.a(a:26)
at com.yourkit.ui.ax$1.mouseReleased(a:16)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.yourkit.c$b.dispatchEvent(a:5)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
arylwen
 
Posts: 1
Joined: Wed Feb 06, 2008 7:51 pm

Postby Anton Katilin (YourKit) » Wed Feb 06, 2008 10:06 pm

Hello,

Which exact version of the profiler do you use (the latest 3.0.3 or an older one)?

Best regards,
Anton
Anton Katilin (YourKit)
 
Posts: 157
Joined: Wed Aug 15, 2007 9:09 pm

Postby Tobbe » Fri Feb 22, 2008 7:58 am

Also have problem with the VS2005 integration. I cant get it to work properly. Tried a couple of things and it seems that youkit has problem with collapsed/hidden text (#regions). Even if code is visible it fails.
Tobbe
 
Posts: 72
Joined: Thu Feb 21, 2008 11:08 am

Postby Anton Katilin » Fri Feb 22, 2008 12:40 pm

This seems a limitation of VS open API. We're searching for workarounds.
Anton Katilin
 
Posts: 5575
Joined: Wed Aug 11, 2004 8:37 am

Postby Tobbe » Wed Apr 02, 2008 10:25 am

Hi again

Any progress on the issue?
Tobbe
 
Posts: 72
Joined: Thu Feb 21, 2008 11:08 am

Postby Vladimir Kondratyev » Tue Apr 08, 2008 9:32 am

We are working on this issue. We'll notify you as soon as it's resolved.

Best regards,
Vladimir Kondratyev
YourKit, LLC
http://www.yourkit.com
"Don't get lost in data, get information!"
Vladimir Kondratyev
 
Posts: 1444
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany

Re: Open declaration in Visual Studio not working

Postby Tobbe » Mon Sep 01, 2008 2:35 pm

Hi again

Any progress on the issue? Would be nice with a minipatch so solve this...
Tobbe
 
Posts: 72
Joined: Thu Feb 21, 2008 11:08 am

Re: Open declaration in Visual Studio not working

Postby Vladimir Kondratyev » Mon Oct 13, 2008 10:56 am

Please try to use latest version 3.0.6 http://www.yourkit.com/dotnet/download/index.jsp
Navigation should work perfectly.
Vladimir Kondratyev
 
Posts: 1444
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany

Re: Open declaration in Visual Studio not working

Postby Tobbe » Mon Oct 13, 2008 11:46 am

First impressions, not so good...

Have an ASP.NET applikation 3-tier (Gui -> business-> data). All in same vs2005 solution.

Most page methods work but not properties. Guessing you are trying to open "get_propertyname" instead och the "propertyname" and then focusing in the get section?!? I have not been able to open any of my asp.net controls methods or properties, the same goes for business and data layer. Inherited methods/properties dont work either.

The message I get everytime is "IDE cannot open method/propertye xxxxxxxxx of class xxxxxxxxxx".
Tobbe
 
Posts: 72
Joined: Thu Feb 21, 2008 11:08 am

Re: Open declaration in Visual Studio not working

Postby Vladimir Kondratyev » Mon Oct 13, 2008 1:22 pm

Tobbe, thanks a lot for feedback. We are investigating issue with properties.
Vladimir Kondratyev
 
Posts: 1444
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany


Return to .NET Profiler

Who is online

Users browsing this forum: No registered users and 2 guests

cron