Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

IIS Applications not showing up in Monitor Applications list

Moderators: Vladimir Kondratyev, Anton Katilin

IIS Applications not showing up in Monitor Applications list

Postby Alec » Wed Feb 06, 2008 10:17 am

Hi,
I'm using Windows 2000 server and .Net 1.1 and YourKit 3.03. I'm having problems attempting to profile ASP.NET applications. I choose "Profile ASP.Net Application", allow it to reset IIS and then start the app in a browser, yet nothing happens. What should i be looking for?

Alec
Alec
 
Posts: 3
Joined: Wed Feb 06, 2008 10:13 am

Postby Alec » Wed Feb 06, 2008 10:18 am

I've just tried the same on a Windows XP machine and a profiler pops up. Any ideas?
Alec
 
Posts: 3
Joined: Wed Feb 06, 2008 10:13 am

Postby Anton Katilin (YourKit) » Wed Feb 06, 2008 10:04 pm

We'll investigate why this can happen. Most likely there should be problems with access right to a shared memory area used to register running profiled applications; it's a known fact that Windows 2000 has some oddities.

Could you please try the following workaround: from the main menu, File, choose connect to remote application, and enter "localhost" as host name.
Anton Katilin (YourKit)
 
Posts: 157
Joined: Wed Aug 15, 2007 9:09 pm

Postby Alec » Tue Feb 12, 2008 3:01 pm

I've tried localhost and 127.0.0.1 and both give me the following message:

No application being profiled can be automattically detected on host ****.

And if i speificy the port,80, I just get the "Connecting to Remote Application" box with a constantly scrolling progress bar.

Alec
Alec
 
Posts: 3
Joined: Wed Feb 06, 2008 10:13 am

Postby Anton Katilin » Tue Feb 12, 2008 7:25 pm

Hello Alec

I've tried localhost and 127.0.0.1 and both give me the following message:

No application being profiled can be automattically detected on host ****.


When an application starts with the profiler, it uses a socket to communicate with the profiler client. The socket is opened on ports in the range 10001-10010; if none of them is available (i.e. all are in use, but in real life this will almost never happen), an arbitrary free port is used.

When you use remote connection to localhost, all the ports in the range are checked in order to detect running profiled application.

Because no applications were detected, this most likely means that there are indeed no profiling application running. For some reason, they didn't start with profiling.

If profiling is enabled, each started .NET application should at least write a log file. If it is on the ignore list, it should write to the log about that.

The logs are created in <use home directory>\.ynp

Please note that if you run ASP.NET in IIS, IIS normally under special system user, so please check appropriate directory.

Do you have such logs on your Window 2000 machine? If yes, could you please send them to us (at support@yourkit.com )?

By the way, could you please check the ignore list on the Welcome screen.
Could you please try if making the list empty changes anything.

And if i speificy the port,80, I just get the "Connecting to Remote Application" box with a constantly scrolling progress bar.


Port 80 is for HTTP, and should not be used for connection to profiled applications from the profiler client.

Best regards,
Anton
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am


Return to .NET Profiler

Who is online

Users browsing this forum: No registered users and 4 guests