Fully featured low overhead profiler for Java EE and Java SE platforms.
Performance monitoring and profiling of Jenkins, TeamCity, Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

Problem with 4.5-eap-build618 - Can't detect Eclipse plugin

Moderators: Vladimir Kondratyev, Anton Katilin

Problem with 4.5-eap-build618 - Can't detect Eclipse plugin

Postby BillEvans » Wed Jul 06, 2005 3:44 pm

I upgraded to the eap version and but it cannot detect Eclipse anymore.

I reinstalled the plugin as directed and Eclipse sees it correctly. However, YourKit is confused...

Any ideas?
BillEvans
 
Posts: 6
Joined: Thu Jun 30, 2005 10:06 pm

Postby Anton Katilin » Wed Jul 06, 2005 4:55 pm

Hi,

I'm afraid I don't understand what the problem is.
Could you please provide more detailed description.

What is the exact version of Eclipse that you are using?
Which build of the profiler do you use?
What is your OS?

If there are any error messages shown by the profiler, could you please post their texts here.
Anton Katilin
 
Posts: 5966
Joined: Wed Aug 11, 2004 8:37 am

Postby BillEvans » Wed Jul 06, 2005 6:24 pm

Eclipse Version: 3.1.0 Build id: I20050627-1435

I originally installed YourKit 4.0 build 566. It accepted the plugin with above version of Eclipse and everything worked fine.

Then I decided to upgrade to YourKit 4.5 build 618 (eap).

So, I uninstalled 4.0 and installed 4.5.

Then when I go to integrate with Eclipse again. It appears to accept, but whenever I do something like "Open Declaration in IDE Editor", it cannot detect the Eclipse plugin and takes me into the "Integrate with IDE" dialog again. Checking in Eclipse reveals the 618 plugin installed, so it is as if the YourKit application doesn't detect it's own plugin.

Does the problem make sense now?
BillEvans
 
Posts: 6
Joined: Thu Jun 30, 2005 10:06 pm

Postby Anton Katilin » Wed Jul 06, 2005 6:59 pm

Maybe the plugin is installed, but fails to start for some reason.

Could you please check the eclipse logs, probably there are error messages about it...
Anton Katilin
 
Posts: 5966
Joined: Wed Aug 11, 2004 8:37 am

Postby Anton Katilin » Wed Jul 06, 2005 7:01 pm

P.S. Eclipse logs are in <workspace>/.metadata/.log

Please make sure Eclipse is closed to make sure logs are flushed.
Anton Katilin
 
Posts: 5966
Joined: Wed Aug 11, 2004 8:37 am

Postby Anton Katilin » Thu Jul 07, 2005 12:14 pm

FYI: we have found another problem with Eclipse 3.1 and YourKit Java Profiler 4.5 EAP build 618. It will be fixed in the next EAP build. The released version 4.0 of the profiler does not have that problem.
Anton Katilin
 
Posts: 5966
Joined: Wed Aug 11, 2004 8:37 am


Return to Java Profiler

Who is online

Users browsing this forum: Google [Bot] and 1 guest

YourKit uses cookies and other tracking technologies to improve your browsing experience on our website, to show you personalized content and targeted ads, to analyze our website traffic, and to understand where our visitors are coming from.

By browsing our website, you consent to our use of cookies and other tracking technologies in accordance with the Privacy Policy.