Fully featured low overhead profiler for Java EE and Java SE platforms.
Performance monitoring and profiling of Jenkins, TeamCity, Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

Exception in 4.0 (build 536)

Moderators: Vladimir Kondratyev, Anton Katilin

Exception in 4.0 (build 536)

Postby andrey_e » Wed Feb 16, 2005 11:21 am

My actions:
- run my J2ME application under WTK22 emulator
- connected to emulator via "Connect to J2ME application"
- clicked "Capture Snapshot of J2ME application"
- profiles shows "Capture Memory Shanpshot" dialog box
- I clicked "Capture"
- get window with exception

Build: 536
JDK: 1.4.2_01
VM: Java HotSpot(TM) Client VM
Vendor: Sun Microsystems Inc.
OS: Windows XP
java.lang.InternalError: !MethodImpl.Got_MethodID_of_ReferenceType_that_is_not_a_member_of_the_ReferenceType_10!
at com.yourkit.m.a.b.a.a.a.aq.int(a:99)
at com.yourkit.m.a.b.a.a.a.z.else(a:48)
at com.yourkit.m.a.b.a.a.a.aj.a(a:114)
at com.yourkit.m.a.b.a.a.a.x.if(a:332)
at com.yourkit.m.a.b.a.a.a.x.ck(a:172)
at com.yourkit.m.a.<init>(a:261)
at com.yourkit.m.a.a(a:657)
at com.yourkit.m.c.a(a:15)
at com.yourkit.ui.i.g$2.a(a:3)
at com.yourkit.ui.d$b.run(a:34)
andrey_e
 
Posts: 5
Joined: Wed Jan 12, 2005 3:13 pm
Location: Kharkov, Ukraine

Postby Vladimir Kondratyev » Wed Feb 16, 2005 11:46 am

Is this exception reproducible?
Vladimir Kondratyev
 
Posts: 1519
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany

Postby andrey_e » Wed Feb 16, 2005 12:09 pm

yes, it happens each time I run my application: bunch of unit tests under J2MEUnit.
If necessary, I can send jad/jar.
andrey_e
 
Posts: 5
Joined: Wed Jan 12, 2005 3:13 pm
Location: Kharkov, Ukraine

Postby Anton Katilin » Wed Feb 16, 2005 1:21 pm

Could you please send jad and jar to [email protected]
Anton Katilin
 
Posts: 5966
Joined: Wed Aug 11, 2004 8:37 am

Postby Anton Katilin » Wed Feb 16, 2005 4:21 pm

It seems we have fixed the problem. Could you please download the latest version from http://www.yourkit.com/download (build 538) and check if the problem is gone.
Anton Katilin
 
Posts: 5966
Joined: Wed Aug 11, 2004 8:37 am

Postby andrey_e » Wed Feb 16, 2005 4:45 pm

yes, it works now :)
Thanks a lot! I even didn't manage to send you jad/jar!
andrey_e
 
Posts: 5
Joined: Wed Jan 12, 2005 3:13 pm
Location: Kharkov, Ukraine


Return to Java Profiler

Who is online

Users browsing this forum: Google [Bot] and 1 guest

YourKit uses cookies and other tracking technologies to improve your browsing experience on our website, to show you personalized content and targeted ads, to analyze our website traffic, and to understand where our visitors are coming from.

By browsing our website, you consent to our use of cookies and other tracking technologies in accordance with the Privacy Policy.