Fully featured low overhead profiler for Java EE and Java SE platforms.
Performance monitoring and profiling of Jenkins, TeamCity, Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

Compatibility of yourkit 3.2 with JDK 1.3

Moderators: Vladimir Kondratyev, Anton Katilin

Compatibility of yourkit 3.2 with JDK 1.3

Postby nirchattop » Wed Feb 02, 2005 10:23 pm

I am currently evaluating yourkit 3.2. I was trying to run my profiled application on jdk1.3.1_09 and came across following error:

YourKit Java Profiler 3.2 #451 cannot start: JVM does not support JVMPI_VERSION_1_1
unable to initialize JVM helper library yjpagent
Could not create the Java virtual machine.


Does your product support JDK 1.3.1_09?

If so, please let me know if I need to use any specific configuration or JVM or agent controller option to make it run.
nirchattop
 
Posts: 5
Joined: Wed Feb 02, 2005 9:56 pm
Location: Stamford

Postby RangerRob » Thu Feb 03, 2005 12:53 am

Hi nirchattop. YourKit 3.2 definately works with JDK 1.3.1. I'm actually using it myself currently since I'm working on a project to see whether our old 1.3 apps need converting to 1.5 and using YJP to find leaks supporting redevelopment.

I've also used the 4.0 build in similar circumstances with 1.3 and no problems.

Can I just make sure you are using the Sun JDK?? Currently YJP 3.2 does not work with the IBM one.
RangerRob
 
Posts: 64
Joined: Wed Oct 06, 2004 7:56 am
Location: United States


Return to Java Profiler

Who is online

Users browsing this forum: Google [Bot] and 1 guest

YourKit uses cookies and other tracking technologies to improve your browsing experience on our website, to show you personalized content and targeted ads, to analyze our website traffic, and to understand where our visitors are coming from.

By browsing our website, you consent to our use of cookies and other tracking technologies in accordance with the Privacy Policy.