Fully featured low overhead profiler for Java EE and Java SE platforms.
Performance monitoring and profiling of Jenkins, TeamCity, Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

Large Remote Snapshot broken

Moderators: Vladimir Kondratyev, Anton Katilin

Large Remote Snapshot broken

Postby masalm » Thu Jan 13, 2005 1:12 pm

I tried taking a really large Memory Snapsshot (>300MB) while remote profiling an application in Tomcat 5.0.24.

It took a long time. When the progress bar reached 49% it stopped and saved the snapshot.
But when I try to open this snapshot, YourKit tells me, it isn't a correct snapshot. :evil:
masalm
 
Posts: 7
Joined: Wed Aug 11, 2004 11:46 am

Postby Vladimir Kondratyev » Thu Jan 13, 2005 4:10 pm

What build are you using? BTW, I didn't catch whether progress reached 100%? Also please make sure that profiler agent and profiler UI are from the same build.
Vladimir Kondratyev
 
Posts: 1519
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany

Postby masalm » Fri Jan 14, 2005 8:41 am

Vladimir Kondratyev wrote:What build are you using?

I'm using build 504.

Vladimir Kondratyev wrote:BTW, I didn't catch wheather progress reached 100%?

No. It never reached 100%. It stopped at 49%, saved the file and the progress bar disappeared.

Vladimir Kondratyev wrote:Also please make sure that profiler agent and profiler UI are from the same build.

They are definetly from the same build.


Another large snapshot did work. There the progress bar also didn't get beyond 49%. But the snapshot was ok.

I think you have a timing problem with large snapshots over a network connection.
masalm
 
Posts: 7
Joined: Wed Aug 11, 2004 11:46 am

Postby Vladimir Kondratyev » Fri Jan 14, 2005 8:53 am

Please send us (at [email protected]) log files that are located at .yjp/logs directory. Also we'll add some extra logging in the next build to track the problem.
Vladimir Kondratyev
 
Posts: 1519
Joined: Tue Aug 10, 2004 7:52 pm
Location: Düsseldorf, Germany

Postby Anton Katilin » Fri Jan 14, 2005 9:41 am

As well, could you please try whether the problem is reproducible with the latest build 508?
Anton Katilin
 
Posts: 5966
Joined: Wed Aug 11, 2004 8:37 am

Postby masalm » Tue Jan 18, 2005 1:17 pm

I just send the logfile via email.

I'll try snapshotting again on thursday with your newest build, when a new profiling session is planned.
masalm
 
Posts: 7
Joined: Wed Aug 11, 2004 11:46 am


Return to Java Profiler

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron

YourKit uses cookies and other tracking technologies to improve your browsing experience on our website, to show you personalized content and targeted ads, to analyze our website traffic, and to understand where our visitors are coming from.

By browsing our website, you consent to our use of cookies and other tracking technologies in accordance with the Privacy Policy.