Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

9.5.6 not working with Wildfly 8.2.0

Moderators: Vladimir Kondratyev, Anton Katilin

9.5.6 not working with Wildfly 8.2.0

Postby cain » Fri Oct 09, 2015 2:56 pm

Since we upgraded to Wildfly 8.2.0, YourKit 9.5.6 doesn't seem work any more. I had to manually configure the standalone.bat to set up profiling, which is fine, but as soon as I try starting Wildfly with profiling, it exits immediately. Below is the contents of the log file that is being generated. I also tried with a trial version of YourKit 2015, but got the same error. It used to work on Wildfly 8.0.0 and 8.1.0. Note that this is failing even without my application deployed.

Code: Select all
[YourKit Java Profiler 9.5.6] [0.000]: Agent_OnLoad: options=disablestacktelemetry,disableexceptiontelemetry,builtinprobes=none,delay=10000,sessionname=JBoss
[YourKit Java Profiler 9.5.6] [0.000]: phase: 1
[YourKit Java Profiler 9.5.6] [0.000]: jvmtiVersion: 30010203
[YourKit Java Profiler 9.5.6] [0.000]: vendor: Oracle Corporation
[YourKit Java Profiler 9.5.6] [0.000]: version: 25.60-b23
[YourKit Java Profiler 9.5.6] [0.000]: info: mixed mode, sharing
[YourKit Java Profiler 9.5.6] [0.001]: can_generate_all_class_hook_events: available
[YourKit Java Profiler 9.5.6] [0.001]: can_generate_exception_events: available
[YourKit Java Profiler 9.5.6] [0.001]: can_access_local_variables: available
[YourKit Java Profiler 9.5.6] [0.001]: can_suspend: available
[YourKit Java Profiler 9.5.6] [0.002]: JVMTI 30010203; 25.60-b23; Oracle Corporation; mixed mode, sharing; Windows 7; 64-bit JVM; JR=1; M=0; I=0; oI=0; u4=1; FOS=0
[YourKit Java Profiler 9.5.6] [0.029]: Successfully registered probe classes: 2
  Registered: com.yourkit.probes.builtin.OSGiFelixSupport$MyProbe1
  Registered: com.yourkit.probes.builtin.OSGiFelixSupport$MyProbe2
[YourKit Java Profiler 9.5.6] [0.048]: error at ConstantPoolInfoReader.cpp:31: Unknown Constant Pool Info tag: 15
cain
 
Posts: 4
Joined: Fri Oct 09, 2015 2:45 pm

Re: 9.5.6 not working with Wildfly 8.2.0

Postby Anton Katilin » Mon Oct 12, 2015 11:04 am

YourKit 9.5.6 is not supported. Could you please provide the log file from the version 2015 agent.
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am

Re: 9.5.6 not working with Wildfly 8.2.0

Postby cain » Wed Oct 14, 2015 7:28 pm

I tried 2015 again and it seems to be working. I must have done something wrong the last time I tried. I also verified that WildFly 9.0.1 Final and 10.0.0 CR2 work as well.
cain
 
Posts: 4
Joined: Fri Oct 09, 2015 2:45 pm

Re: 9.5.6 not working with Wildfly 8.2.0

Postby Anton Katilin » Wed Oct 14, 2015 7:50 pm

Thank you for the notification.
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am


Return to Java Profiler

Who is online

Users browsing this forum: No registered users and 8 guests