Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

Object recording not working

Moderators: Vladimir Kondratyev, Anton Katilin

Object recording not working

Postby jvyas » Wed Sep 23, 2015 12:47 am

Hi,

I am using yourkit to attach to a remote process in production and using ssh port forwarding to debug a excess garbage collection issue.

But when I click on "Record Object Allocation", the client show a pop up, "Loading classes to instrument..." and gets stuck there. I tried increasing the minimum size to record allocation, and increase sampling rate, but that doesn't help.

Has anyone else seen this issue? I am using YourKit Java Profiler 2015 build 15074.

Thanks,
Jayesh
jvyas
 
Posts: 1
Joined: Wed Sep 23, 2015 12:31 am

Re: Object recording not working

Postby Anton Katilin » Tue Oct 06, 2015 2:12 pm

Hi Jayesh

The message "Loading classes to instrument..." means you're using the attach mode:
https://www.yourkit.com/docs/java/help/attach_agent.jsp

As a workaround please run the profiled application with the profiler agent instead:
https://www.yourkit.com/docs/java/help/ ... remote.jsp

To investigate why it works that slowly in attaching for you, we need the profiler agent log file ~/.yjp/log/<session name>-<pid>.log from the remote machine.

Best regards,
Anton
Anton Katilin
 
Posts: 5576
Joined: Wed Aug 11, 2004 8:37 am


Return to Java Profiler

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 6 guests

cron