Fully featured low overhead profiler for Java EE and Java SE platforms.
Ultimate profiling and monitoring solution for Gradle, Maven, Ant, JUnit and TestNG.
Easy to use performance and memory profiler for .NET framework.

IBM Power P775 Compatibility

Moderators: Vladimir Kondratyev, Anton Katilin

IBM Power P775 Compatibility

Postby dlauf » Wed Jul 29, 2015 2:43 pm

I am able to install and run the YourKit Java Profiler and license server on x86 but I get errors trying to start the client application on our IBM Power P775 system which is ppc64. Anyone have any ideas?

Versions tried: YourKit Java Profiler 2014, build 14120 and 2015, build 15068.
Java versions tried: 1.7.0, 1.7.1 and 1.8.0

-bash-4.1$ ./yjp.sh
[Yourkit Java Profiler 2015 build 15068] Log file: /gpfs/gpfs01/drlauf/.yjp/log/yjp-91909.log
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:95)
at sun.reflect.DelegateingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:495)
at com.yourkit.Main$2.run(a:16)
Caused by: java.lang.IllegalAccessError
at com.yourkit.b.h.<init>(a:92)
at com.yourkit.b.h.<clinit>(a:209)
at com.yourkit.b.d.a(a:1)
at com.yourkit.g.au.do(a:33)
at com.yourkit.g.au.<clinit>(a:11)
at com.yourkit.Main1.entry(a:364)
... 5 more
dlauf
 
Posts: 4
Joined: Wed Jul 29, 2015 2:30 pm

Re: IBM Power P775 Compatibility

Postby dlauf » Wed Jul 29, 2015 8:50 pm

Problem resolved. We have a stripped down OS installed and needed RPMs.

yum -y groupinstall "Desktop" "X Window System"
dlauf
 
Posts: 4
Joined: Wed Jul 29, 2015 2:30 pm

Re: IBM Power P775 Compatibility

Postby Anton Katilin » Thu Jul 30, 2015 9:32 am

Thanks for the notification that the problem was resolved.
Anton Katilin
 
Posts: 5574
Joined: Wed Aug 11, 2004 8:37 am

Re: IBM Power P775 Compatibility

Postby dlauf » Fri Jul 31, 2015 2:55 pm

Trying to run on another P775 system and this system is throwing the same java.lang.IllegalAccessError even after installing the "Desktop" and "X Server System" rpm groups. I wish i knew the complete list of RPM requirements for this application to start. :(
dlauf
 
Posts: 4
Joined: Wed Jul 29, 2015 2:30 pm

Re: IBM Power P775 Compatibility

Postby dlauf » Fri Jul 31, 2015 9:06 pm

This system is working now too. Had to set JAVA_HOME to a different version. This system has 4 versions of Java installed and only 1 will allow the yjp.sh to start without throwing the below error. Issue resolved.
dlauf
 
Posts: 4
Joined: Wed Jul 29, 2015 2:30 pm

Re: IBM Power P775 Compatibility

Postby Anton Katilin » Mon Aug 03, 2015 11:25 am

Thanks again for the feedback.
Anton Katilin
 
Posts: 5574
Joined: Wed Aug 11, 2004 8:37 am


Return to Java Profiler

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 6 guests